Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 14:00 UTC
Update
We have now confirmed the outage date for the upcoming H100 cluster relocation in our US-1 data centre. The maintenance will begin on Wednesday, October 22, 2025 at 8:00 AM MT (14:00 UTC).
The relocation process is expected to take up to 24 hours, and we will notify you immediately if the schedule changes. This relocation is part of our continuing effort to enhance infrastructure reliability and prepare for future expansion.
We appreciate your patience and understanding during this essential work.
Posted Oct 15, 2025 - 23:31 UTC
Scheduled
We will be performing a major maintenance and relocation of all H100 nodes currently hosted in our US-1 data centre. This work is necessary to enhance infrastructure reliability and support future expansion. This outage will take place between October 21, 2025 and October 31, 2025.
All H100 nodes in US-1 region will be shutdown for up to 24 hours of service interruption during the relocation window. A confirmed outage date will be shared as soon as we have further details.
We sincerely apologise for any inconvenience this essential work may cause and thank you for your patience and understanding.
Posted Oct 15, 2025 - 09:36 UTC
This scheduled maintenance affected: US 1 DataCenter.