Summary The underlying issue has been resolved. New clusters are now creating successfully and transitioning to an Active state as expected.
Impact Cluster creation and reconciliation processes are now fully operational.
Current Status All systems are functioning normally. We apologise for any inconvenience this issue may have caused. We will continue to monitor the situation closely. If you experience any further issues, please contact us at support@hyperstack.cloud.
Posted Apr 29, 2026 - 14:11 UTC
Identified
Summary We have narrowed down the issue to just cluster creation. Reconciliation for existing clusters (incl adding/removing nodes/groups) aren't affected.
Impact Clusters that depend on NVIDIA Helm charts may fail to create.
Observed Error 502 Bad Gateway when attempting to fetch index.yaml from the NVIDIA Helm repository.
Current Status Investigation is ongoing. We are monitoring the upstream NVIDIA repository and assessing potential mitigation options.
Next Update We will provide an update as soon as additional information or mitigation steps become available.
Posted Apr 29, 2026 - 13:38 UTC
Update
We are continuing to investigate this issue.
Posted Apr 29, 2026 - 10:39 UTC
Investigating
Summary We are currently investigating an issue affecting cluster reconciliation. The NVIDIA Helm chart repository (https://helm.ngc.nvidia.com/nvidia) is returning errors and appears to be unreachable.
Impact Clusters that depend on NVIDIA Helm charts may fail to reconcile to their desired state.
Observed Error 502 Bad Gateway when attempting to fetch index.yaml from the NVIDIA Helm repository.
Current Status Investigation is ongoing. We are monitoring the upstream NVIDIA repository and assessing potential mitigation options.
Next Update We will provide an update as soon as additional information or mitigation steps become available.
Posted Apr 29, 2026 - 10:36 UTC
This incident affected: Norway 1 Datacentre, Canada 1 Datacentre, Hyperstack Portal, Hyperstack API, US 1 DataCenter, and Canada 2 Datacentre.